Monday, 15 January 2018

Internet Browsers

Due to upcoming changes in financial and data security requirements, some of the Library's information resource suppliers have advised that some older browsers will no longer work with their resources.

The Library's advice is that you ensure that the browsers installed on your desktop and mobile devices are updated to recent versions.

In particular, the change is that some platforms will not support Transport Layer Security protocol version 1.0 (TLSv1.0) after 31st January 2018, and will instead be using TLSv1.1.

Browsers that are known to be non-compliant include Internet Explorer 8, 9, and 10 (although TLSv1.1 can be activated manually in IE 10); the earliest Internet Explorer version that supports TLSv1.1 or higher by default is 11. For a complete list of browsers that support TLSv1.1 or higher, including browser version and operating system, please review the following table: https://en.wikipedia.org/wiki/Transport_Layer_Security#Web_browsers


No comments:

Post a Comment