Tuesday, 5 August 2014

Scopus & Internet Explorer 7 (IE7)

From Scopus' blog today :

As of September 6, Scopus is discontinuing its support for Internet Explorer 7 (IE7). This means that users currently using IE 7 or any previous versions of Internet Explorer will no longer be able to access Scopus.com after this date.

For the purpose of providing an optimal user experience and maintaining platform performance, Scopus is discontinuing the support of older browsers which do not support the new functionalities in the upcoming September 6 release. This decision is also in line with Microsoft ceasing its support for Windows XP and IE7 per April 2014.

In order for our users to continue benefitting from Scopus’ new features and functionalities, we recommend that you upgrade your browser to IE 8 or higher or use Google Chrome or Firefox browsers.
Scopus to cease support of Internet Explorer 7 (IE7) | Scopus Blog | Elsevier

No comments:

Post a Comment